A video and animated text question


#41

Here's what's happening with the animated text...

I'm quite surprised to realize squarespace code handling behind the curtains is not quite reliable. Depending on how you write that text you can have many different results.

So, for now, I've just copied the text from the other page, and it's working.

I also tweaked a bit with the script, but that was not the issue at all. The text currently working at studio is not tweaked. But this is: http://clockworkstudio.squarespace.com/studio-weird-bug

Trying to explain in short technical terms, the squarespace-generated-code that do work, split each line using <span>. This weird behaviour there, however, is also code generated by squarespace but it contains no <span>. Just <br>, which makes it harder to identify different paragraphs, code wise, for my code to inject text into typed.js.

All that means that to get reliable results we'll probably need to do it in another way because by keeping it this way whenever you modify the text (which you should be able to do) there's a risk it won't work. Even if I'd go ahead and write more code to account for this, I fear there might be even more issues to arise.

Any wysiwyg code generator have this kind of problem, I just never realized sqsp one did have it this big.


#42

I am looking at the page through a iPhone and I see that the text animation just based on two sentences?

Could you change it so it begins with clockwork is norges mest effektive reklamestudio" and that stands for 5 seconds, then the rest of the sentences stands in two seconds?

And maybe double the "delete speed"?

Thank you smile


#43

I also see that the text that pops up when you click on Andre De Young need to be left aligned. Now its centred.

Thanks smile


#44

Hmm, please look at the "video_sbs" located under "produksjoner" in Not linked. It seems that you have done something to make sure that you can't left align normal text? I can left align H3 text, but not normal?


#45

Another question regarding People Bio. How can I differentiate between employees at Clockwork and employees at Schjærven film?

You see, there at two lists with people, Clockwork and Schjærven. Could you make a new "people gallery" that has only Schjærven film employees.

I.e.
People gallery Clockwork - only people working at Clockwork

and

People galley Schjærven - only people working at Clockwork

I guess this would need a new code block targeting the new gallery?

Regards,
Tor M


#46

I have also added more people under "people gallery", but none of them shows up.


#47

Aha, I see that the newly added people does show up, but not under "folk". They appear under "People Click".
How can I make sure that they are visible on the "correct" page?


#48

I'm not at my home office now, but I'll check those later today. Squarespace admin doesn't work on mobile, unfortunately.

There should be no problem adding more list of people. The new one I've created the gallery inside the page, so I wasn't using the same gallery. You can, however, create a gallery and just choose it, and it could be the same gallery.


#49

Fixed the issue with using squarespace to write the text... Now we're going to use markdown! That way there's no mistake or funky HTML sqsp might generate. It is a bit more limited than squarespace regular text block in some senses, and it does have more options in other senses. But we can style it more with Custom CSS, such as this one used to align it center:

div.sqs-block-content h3, h3#animated {
  text-align: center;
}

Also added more text to it and reduced the deletion delay so it's faster, as you asked.

I haven't touched people click alignment, nor have I noticed if it was left aligned before. That's weird. I've added a code to do it anyway.

As for not being able to align anything else other than center (and sometimes right), this isn't happening only on video_sbs at all (a page I've never touched either). It's everywhere! Even on a new page. This is so much weirder than the people click alignment there... But maybe they're related. I tried removing all Custom CSS, which might be causing something, but as expected it wasn't. Quite a new bug to me and I don't think it's related to anything I've done because it looks like it appeared when I wasn't doing anything! In any case, I'll keep on investigating this. stuck_out_tongue_winking_eye

And since you've already added everyone into people gallery, I went ahead and changed the one being used before on the main page's gallery block to that one.


#50

All right, now all the text alignment is fixed!

It was a few bad CSS codes sneaking in Code Injection through Styles. And this fix made that last piece of code to align h3 there also bad and unnecessary, so I removed it as well.

I hope we're nearing an end here! smile


#51

You are doing great work, squashing the bugs smile

Two things:

1) Animated text need to be centered (not left aligned)

Guess the code below does the trick, but I am not sure how to use it correctly.

div.sqs-block-content h3, h3#animated {
text-align: center;
}

2 ) Two people gallery:

Another question regarding People Bio. How can I differentiate between employees at Clockwork and employees at Schjærven film?

You see, there at two lists with people, Clockwork and Schjærven. Could you make a new "people gallery" that has only Schjærven film employees.

I.e.
People gallery Clockwork - only people working at Clockwork

and

People galley Schjærven - only people working at Clockwork

I guess this would need a new code block targeting the new gallery?

Could you help me with this?

I think we are close to an end now smile


#52
  1. Oh yeah, forgot markdown can't align and we need CSS there. Done.

  2. My fault. It's really not working with 2 galleries on the same page. Working on it.
    And (couple moments later) done.

I've put the main code inside a Code Block on the top of the page, that way it will work only for that page, regardless if you open it directly or inside an index. That code block could go into global Code Injection if you prefer. And now each gallery just need a Code Block like this before them to be activated:

<span class="gallery-hover-click" id="gallery-people">
  Loading next gallery found below...
</span>

( The id="gallery-people" there should be unique, but it's not really being used anyway. )


#53

This is looking good now, you have done great. I am going to have a "sit-down" with the client tomorrow to walk through the site.

One little observation though,

Look at the pictures that is at the bottom of the page:

And if I go into "edit mode", I cannot longer see the Gallery.

The "gallery block" is there, but the preview is gone. Do you know why?

Thank you!


#54

Yeah, it's because of these lines:

  .sqs-gallery-container {
    display: none;
  }

I've put them there to make sure the galleries for the folks page, that should never be shown, would in fact never show. Then, when all script is done, the very last command line is this, which shows galleries that had nothing to do with it:

    $('.sqs-gallery-container').show();

Since the editor disables the scripts, it never brings the galleries back while on edit mode.

There's little I could do to go around this, if you feel it's needed... That is, short of trying to think of novel ways to achieve that or simply removing this little touch. Most people will probably never notice if the browser even ever renders the gallery. It would only show for a very brief period, which might only happen if I remove that.


#55

Hi,
Just want to thank you on behalf on my client. They are really happy with the website, and appreciate all the tweaks you have made to the site.

I hope that I can bring you more work in the near future.
I´ll end with a bit strange question, but is comes from my client: "how much time and cost will it be to build exactly the same page in wordpress? Is that something you could do if this is a road my client want to take?

Only reason for this is that they may want to host it themselves, and not be locked with a proprietary Squarespace solution.

Thanks again for your fast and great service!

Regards,
Tor Martin


#56

Thanks for the feedback! Really appreciate it. smile

In fact my work here is meant to be with any technology. It just happened so far my marketing only brought me squarespace work, by chance. So I haven't really got an opportunity to play much with wordpress recently.

That being said, the way I'm working now, the cost would probably be about the same (*), but I could take about double the time to adapt. Except...

(*) I must now admit one caveat: you were my first paying customer since I raised my price table, and I had had a few requests for a whole month without anyone willing to move forward... So I was eager to please (plus I had some extra time in hands). Meaning it's a price I probably won't be able to keep because it didn't really covered my costs. So, unfortunatelly, I'm still struggling on how to make the whole business work.

Right now what I would have done is I'd take the upfront payment, analyze if I had made a proper first judgement, realize I haven't, then charge more to adjust to what I would need to do or give a full refund. And after analyzing, I should either have known it would cost around U$690 (if I properly recall, I don't really keep all my calculations around) or at least have said I wouldn't be able to move forward unless we reached an agreement to "pay as it goes".

And if you're wondering about moving away from squarespace in the future, there's at least one more option to consider:

Anyway, thank you again as well for choosing me! smile


#57

Hi :smile:

I am trying to recreate the gallery on another page, and I wonder if you can share the .png files (cross105.png & magnifier52.png)

I reckon I dont need the magnifier, but It could be useful to have.

Thanks in advance!


#58

Hi again Caue,

I invited you as an administrator to this page: schjarvenfilm.squarespace.com

It is identical (almost) to clockworkstudio.squarespace.com.

But I cant get the gallery-function that you made to work. I have copied every script, and used the same name on folders and galleries. Could you take a quick peek just to see if there are som obvious errors?

Regards,
Tor Martin


#59

You mean those files already on github?

Sorry, I couldn't quickly find anything too obvious there. I'll try to look again later on.


#60

Hi,

You know, I figured it out. I just forgot the Gallery-block that is below one of your scrips. Now its working nicely.

Have a nice day!